Back
Resolved

Calendar Sync is a bit delayed

Started 3 Apr at 12:18pm PDT.

greminders.com
Created

New Events / Updated Events may take up to 2 hours to reflect in GReminders, we are working through some delays in the sync. Everything is operational but just a bit delayed. We should have this fully resolved later today. Thank you for your patience.

The sync delay issue is fully resolved as of 4pm PT.

Posted 3 Apr at 12:18pm PDT.