Back
Resolved

Google Calendar Sync Delayed

Started 8 Aug at 10:21am PDT.

greminders.com
Created

We are currently experiencing some delays in Google Calendar Sync. Up to 1-2 hours of latency in some cases for Google Calendar Users. We are investigating the issue and expect to have this resolved soon.

This issue is resolved, we are still investigating the root cause.

Aug 10: We believe we have identified the root cause of the latency issues and have deployed a patch. We will continue to monitor the situation.

Posted 8 Aug at 10:21am PDT.