Back
Resolved

Office 365 Users may experience issues with Public Booking Pages

Started .

greminders.com
Created

Microsoft Office 365 is having issues:
https://x.com/MSFT365Status
https://downdetector.com/status/microsoft-365/
https://www.forbes.com/sites/maryroeloffs/2024/11/25/microsoft-outage-outlook-and-teams-restoration-time-unclear-as-company-deploys-fix/

Microsoft is working on a resolution here

11/26 - Microsoft has resolved all their issues and we are not seeing any more errors on our end as a result of this.

Posted .