Back
Resolved

Redtail API Slowness / High Latency

Started 9 May at 11:12am PDT.

greminders.com
Created

Redtail customers will experience slowness within the GReminders App due to Redtail CRM latency issues. Redtail is aware of the issue and it working to address this.

Posted 9 May at 11:12am PDT.