Back
Resolved

Site Outage

Started .

greminders.com
Created

GReminders experienced a site outage between 4:12am - 5:52am PT. This was due to a database locking issue. We are investigating this and will provide full root causes analysis shortly. We apologize for the inconvenience.

RCA:
Due to nightly cleanup that happens regularly some tables that were trying to be removed was being blocked by some larger read queries basically tar-pitting one of the primary databases, causing the entire app to become "frozen" and unreachable.

We have identified the queries and have patched them. We do not expect this see this issue again. We apologize for the inconvenience this may have caused.

Posted .