Back
Resolved

Support Email Outage

Started 8 Apr at 01:31pm PDT.

greminders.com
Created

9:30am PT We are having issues receiving Support Email due to a Google Workspace Partial Outage. This means Support email responses to you are delayed.

We expect this to be resolved shortly.

As of 3pm PT all Support emails are flowing again. Our support team is catching up responding to all your requests now.

Posted 8 Apr at 01:31pm PDT.